Back to overview
Degraded

FirstStreet.org Services Degraded

Mar 19 at 01:57pm EDT
Affected services
FirstStreet.org
First Street API
GraphQL API
Flood Map Tiles
Wildfire Map Tiles
Heat Map Tiles
Wind Map Tiles
Air Quality Map Tiles

Resolved
Mar 19 at 02:36pm EDT

Availability, services and performance has been restored.

Updated
Mar 19 at 02:30pm EDT

We have isolated the issue and have begun some rollback procedures within an internal service that may have caused the degraded performance. We'll continue to provide updates as services become healthy.

Created
Mar 19 at 01:57pm EDT

The infrastructure team is investigating degraded performance across First Street services.